Phone Version: Articles Libraries Display Problem

August 29, Thu
Affected Service: Website & Blog Server
  • Investigating
    In the URL: https://www.swcare.org/projects there is a display problem. We are investigating it in the meantime

    11:16, Aug 20 EEST
  • Resolved
    Now everything display properly in our phone version website. If you find anything else, don’t hesitate to report it at http://link.swcare.org/analyze

    15:07, Aug 29 EEST
Back to current status