Downgrade Hosting Plan

April 20, Mon
Affected Service: Website & Blog Server
  • Update
    After our latest communication, we move on with the downgrade of your business hosting plan to simple premium hosting plan to continues to have the same features as the previous one but without receiving online payments.

    15:19, Apr 20 EEST
  • Identified
    The payment couldn’t proceed from your bank’s end. We can’t continue the process. The website is down and it will remain down until you resolve the problem with your bank

    15:21, Apr 20 EEST
Back to current status